Support for TFS 2010

Jul 14, 2010 at 12:43 AM
Edited Jul 14, 2010 at 11:36 AM

Does MSBuild Extension Pack v4.0 "TFSSource" supports Team Foundation Server 2010? My msbuild used to work with tfs 2008 but now i get the following: Unable to resolve TF.exe path. Assuming it is in the PATH environment variable. TF Operation: Get Executing tf.exe get "C:\..." /noprompt /recursive Win32Exception: The system cannot find the file specified Done executing task "MSBuild.ExtensionPack.VisualStudio.TfsSource" -- FAILED.

This is the command I send:

<MSBuild.ExtensionPack.VisualStudio.TfsSource TaskAction="Get" ItemPath="$(WorkspaceFolder)\Database Schema" Version="2010" WorkingDirectory="$(WorkspaceFolder)"  />

 

 If I omit the Version="2010" from the command, I get:

Exit Code 100. Nothing Succeeded: Unable to determine the workspace.

Coordinator
Jul 14, 2010 at 9:48 AM

Sorry, Version="2010" is not supported. It will be in the August release.

If you add "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE" to your Path environment variable it should work. It should also work if you have VS2008 installed, but I'm guessing you only have 2010.

Mike

Jul 14, 2010 at 3:13 PM

Thanks Mike.

I saw you started the change this morning! ;-)

 

Jul 14, 2010 at 8:48 PM

I ran into the same problem when converting to TFS 2010 2 nights ago. Adding C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE to the Path environment variable on the build servers worked; however; that was not the only error I received. I was also receiving the following error when running <MSBuild.ExtensionPack.VisualStudio.TfsSource TaskAction="UndoCheckout

Exit Code 100. Nothing Succeeded: Team Foundation Server [tfsservername] does not exist or is not accessible at this time.
Technical information (for administrator):
The request failed with HTTP status 403: Forbidden.

The reason was that it was executing tf.exe undo using the VS2008 tools path
Executing c:\Program Files\Microsoft Visual Studio 9.0\Common7\Tools\..\IDE\tf.exe undo

Without knowing that TFS 2010 was not yet supported, I looked at the documentation and found the Version parameter. I passed Version="2010" without changing anything else, it fixed the problem and started using the VS2010 tools path.

I’m using version 4.0 of the Build Extension Pack.