Sync task is not working with sync 1.0 and 2.1 installed

Oct 13, 2010 at 3:39 PM

I am trying to use the FileSystem.Sync task but it is throwing an exception:

COMException: Retrieving the COM class factory for component with CLSID {565AEDBF-3108-4405-AF1F-9C2C25925DAE} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

The framework is installed (this is a new corporate image)... even 1.0 SP1 is installed. I am running an X64 computer and it looks like x64 Sync is installed. I can't install x86 sync frameworks side-by-side.

Oct 13, 2010 at 5:16 PM

For some reason it's fixed... I had installed 2.1 framework, didn't work, then uninstalled it, and after coming back to the issue later, seems to have fixed it. The whole time 1.0 has been installed.

Oct 13, 2010 at 8:15 PM

The reason it is fixed is because I tried running the x86 1.0 installer and even though it "failed" it did enough to copy over the runtime DLLs to the Program Files (x86) folder and register them. After that, it worked.

Sep 17, 2012 at 2:35 PM

Try changing the "Plataform Target" to "any CPU" from build properties of project.