MSBuild.ExtensionPack.Web.Iis7Website fails on remote machine

Dec 8, 2011 at 12:06 PM

Hello all.

I'm trying to configure a IIS7 Website via MSBuild and got stuck getting even a simple task running. Since I'm pretty new to MsBuild anyway my approach may be totally wrong. Any help is greatly appreciated.

Here's one of the easy Tasks that do not run:

            <Output TaskParameter="Exists" PropertyName="SiteExists"/>

Running MsBuild with this results in a COMExeption with the error code 800706ba "COM-Classfactory for Remote Component with CLSID {2B72133B-3F5
B-4602-8952-803546CE3344} could not be called from computer"

Any ideas?

Kind regards


Dec 12, 2011 at 10:15 AM

Narrowed the problem to being a Firewall issue. The information provided here ( didn't help though.

Configuration is:

- Windows Server 2008 R2
- IIS 7.5 with Management Service enabled
- WebDeploy 2.0 (do I even need this?)
- MSBuild ExtensionPack

Question is how to configure the server's firewall to enable remote configuration using the Web tasks?

Dec 18, 2011 at 10:11 PM

Are you running this from a server with IIS7 assemblies available?

Jan 5, 2012 at 10:27 AM

You mean the Extension Pack IIS7 assemblies? Sure. Do they have to be installed on the server as well? How would that explain that the remote deployment works when the firewall is down?

Jan 31, 2012 at 3:30 PM

Sorry I didn't read your reply properly. Did you figure out the firewall setting?



Feb 2, 2012 at 12:45 PM


thanks for coming back to me.

To enable the Task on a remote W 2008 Server with an enabled firewall I had to set a fixed enpoint port for the DCOM component "ahadmin" and then add a firewall rule for incoming traffic on that port.

This link made my day:

If Share Point is installed as well you may have to change some persmission in the registry in advance. This is explained here:

Only difference is the actual key to be changed, for ahadmin it is: HKEY_CLASSES_ROOT\AppID\{9fa5c497-f46d-447f-8011-05d03d7d7ddc}

Now everything works just perfect!

Feb 2, 2012 at 1:29 PM

Great, thanks for the details Markus... Mike