FxCopPath issue

Coordinator
Apr 18, 2012 at 5:02 PM
<cite class="fn">Chandrashekar Vuppala</cite> says:

Hi Mike,

I am using fxcop activity given in MSBuildExtensionPack, but I have a issue setting up fxcop path for the below task. By default fxcop is looking at C:\program files\Microsoft fxcop 1.36\.
On my server it is located at C:\program files (x86)\Microsoft fxcop 1.36\ and I am getting error FxCopCmd.exe was not found in the default location. Use FxCopPath to specify it. Searched at: C:\Program Files\Microsoft FxCop 1.36 and \Microsoft FxCop 10.0

Whne i used Fxcoppath I am getting Access denied /r error.

Can you please guide me how to use fxcop task here.

Thanks & Regards,
Chandra Vuppala.

Coordinator
Apr 18, 2012 at 9:43 PM

Can you post the  Access denied /r error.

Jun 6, 2012 at 8:48 PM

I have encountered the same issue after setting the FxCopPath property to a valid directory. I tried running msbuild elevated, but no go. This is an automated build setup.

error : Win32Exception: Access is denied\r

Jun 6, 2012 at 8:53 PM

Figured it out. Resolution is that the the FxCopPath needs to include the executable as part of the path, e.g. c:\builds\mytoolspath\fxcopcmd.exe