Exception using IIS7AppPool to stop pool in IIS8.5 (Windows Server 2012)

May 22, 2014 at 3:41 PM
Hi there,

we have several quality environments being deployed with the same MSBUILD script normally to Windows Server 2008/Windows7 and IIS 7.5.

Now we have a new target environment that runs IIS 8.5 in Windows Server 2012.
At a given time, we need to stop some IIS pool before publishing an application which is throwing the following exception:
"COMException: Retrieving the COM class factory for remote component with CLSID {2B72133B-3F5B-4602-8952-803546CE3344} from machine MyMachineName failed due to the following error: 800706ba MyMachineName."

I've tried installing IIS server roles (Management scripts and tools, Management Service, etc.) as suggested in a previous post but with the same result.

Is the IIS7AppPool task really supported in IIS8 ?

Thanks in advance!

Best regards,
Ricardo Guerra
May 26, 2014 at 10:55 AM
Edited May 26, 2014 at 10:56 AM
Please log all discussions as issues on GitHub. This project has moved.

I'll try take a look at IIS8.5 soon.
Marked as answer by mikeFourie on 5/26/2014 at 3:57 AM
May 26, 2014 at 12:17 PM
it works for me. I think you have some sort of permission issue. can you try "disabling and re-enabling the "Configure Server Remote Management" from the Server Manager console"