MSBuild.ExtensionPack.Compression.Zip task

Jun 26, 2012 at 8:25 PM

Hi,

I running into a really strange problem when I use the zip task in my build script.  When the task is creating the zip file, it's misses a couple of files.  So even though the file is specified to be zipped up, it's missing from the zip file. My build is running on a Windows 7 64 bit box using msbuild 3.5.  It runs fine on an Windows XP box.  Wondering if anyone has ever run into this problem?

***************** Script excerpt *****************************

<ItemGroup> <ZipFiles Include="..\$(Configuration)\Admin\**\*.*"/> <ZipFiles Include="..\$(Configuration)\BackOffice\**\*.*"/> <ZipFiles Include="..\$(Configuration)\Billing\**\*.*"/> <ZipFiles Include="..\$(Configuration)\POS\**\*.*"/> <ZipFiles Include="..\$(Configuration)\OnlineOrdering\**\*.*"/> <ZipFiles Include="..\$(Configuration)\SEEIS\**\*.*"/> <ZipFiles Include="..\$(Configuration)\ETimeLog\**\*.*"/> <ZipFiles Include="..\$(Configuration)\XIF\**\*.*"/> <ZipFiles Include="..\$(Configuration)\XLink\**\*.*"/> <ZipFiles Include="..\$(Configuration)\XLinkPatientStagingService\**\*.*"/> <ZipFiles Include="..\$(Configuration)\XLinkStagingService\**\*.*"/> <ZipFiles Include="..\$(Configuration)\XLinkWcfService\**\*.*"/> <ZipFiles Include="..\$(Configuration)\DC\**\*.*"/> <ZipFiles Include="..\$(Configuration)\HL7_EW\**\*.*"/> <ZipFiles Include="..\$(Configuration)\*.msi"/> </ItemGroup>

<Target Name="CreateZipFile"> <MSBuild.ExtensionPack.Compression.Zip TaskAction="Create" CompressPath="..\$(Configuration)" CompressFiles="@(ZipFiles);" RemoveRoot="..\" ZipFileName="..\$(Configuration)\Deployment_web_apps.zip"/> </Target>